My browser is unsupported or outdated


I cannot load the ClassDo website. What should I do?

There are various reasons for this problem to occur, it could be because:

  • your browser is unsupported
  • your browser is outdated

Please ensure that you are only accessing ClassDo through Chrome browser or Safari. Follow the steps below to solve your browser problem.


For Windows™ PC/laptops, Chromebooks, Android™ devices, macOS devices

If you do not have one installed, download Google Chrome for free. If your Chrome browser is not up to date, please update Chrome. DO NOT use Mozilla Firefox, Microsoft Edge, Internet Explorer, Safari for Windows or Netscape.

For iOS devices and iPadOS™ devices:

  • Safari (version 12.1 and above)

To keep Safari up to date, update iOS on your iPad/iPhone.DO NOT use the Google Chrome app the App Store for iPad and iPhones.

We also highly recommend that you set your browser on automatic update so that it will be automatically updated when a new version is available.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us